Verschlimmernder Zustand nach .fbx reimport

  • Hallo Forum,


    es ist mal wieder soweit, ich habe eine Seltsamkeit festgestellt (Problem).


    Ich habe ein .fbx in die UE importiert, dieses mit den richtigen Materialien eingestellt und als Modell für meinen PlayerCharakter verwendet. Alles hat wunderbar funktioniert. Jetzt stelle ich aber fest, wenn ich das .fbx über die UE REimportiere (auch wenn sich im .fbx nichts verändert hat) treten Fehler bei der Darstellung meiner Materialien auf.


    Ich habe DynamicMaterials erstellt um eine simple Düsenantriebsfunktion darzustellen und an- und ausschaltbare Scheinwerfer. Der Fehler betrifft aber auch Materialien und Teile des Mesh, bei welchen ich in diese Richtung nichts eingestellt habe. Nenne dies nur der Vollständigkeit halber.


    Fehler: Wenn ich im Editor nahe an meinem Mesh bin, werden die Materialen mitsamt der Texturen alle richtig angezeigt. Scrolle ich jetzt aber vom Mesh weg, tauscht sich das Material eines Teiles des Mesh aus durch andere Materialien. Schwer zu erklären, siehe Sceenshots.

    Das Problem verschlimmert sich zunehmend, mit jedem weiteren reimport.


    Fehlersuche: Habe bemerkt, dass sich das Problem beseitigt wenn ich im Editor LOD auf 0 stelle, bei allen anderen Einstellungen erscheint weiterhin der Fehler. Dies funktioniert allerdings nur im Editor, nicht in der Spielesimulation.



    Jemand eine Idee was hier los ist, wer hat einen Tipp in Richtung der Lösung? Vielen Dank

    • Offizieller Beitrag
    • Hilfreich

    Es ist manchmal schwierig genau zu sagen, was das Problem ist, da ich deinen Workflow nicht kenne.

    Aber das Problem hat vermutlich, wie du bereits festgestellt hast, etwas mit den LOD-Stufen zu tun.

    LOD-Stufen bedeuten, dass es für dein Mesh mehrere Versionen gibt: eine Version mit hoher Polygonanzahl, eine Version mit niedriger Polygonanzahl und möglicherweise Zwischenstufen.

    So gibt es LOD0, LOD1, LOD2 usw.

    Die LOD-Stufe wird in der Regel ab einer bestimmten Kameradistanz gewechselt, und ich glaube, genau das passiert in deinem Fall auch.

    Durch LODs können nicht nur Meshes gewechselt werden, sondern auch Texturen.

    So kann ein Mesh in 1 km Entfernung eine Polygonanzahl von 300 Tris und eine 128² px Textur haben, und wenn du direkt davorstehst, eine Polygonanzahl von 5000 und eine 2k Textur.

    Die Frage ist, warum hast du überhaupt LOD-Stufen? Was willst du damit erreichen?

    Hast du das Mesh selber erstellt und dir dabei etwas gedacht oder ist es ein Mesh, das du irgendwo heruntergeladen hast und das jetzt Probleme macht?


    Lösungen

    1.Du könntest zum Beispiel beim Export der FBX-Datei einfach angeben, dass keine LOD-Stufen mitexportiert werden sollen. Dann sollte das Mesh keine Probleme mehr machen.

    2.Du könntest in Unreal die LODs einfach rauskicken so dass dein Mesh oder LODs funktioniert.

    3.Du könntest die Distance der LOD anpassen so das der Wechsel der LOD Stufe später einsetzt.

  • Die Frage ist, warum hast du überhaupt LOD-Stufen? Was willst du damit erreichen?

    Hast du das Mesh selber erstellt und dir dabei etwas gedacht oder ist es ein Mesh, das du irgendwo heruntergeladen hast und das jetzt Probleme macht?

    Ja, das ist schnell beantwortet, weil ich keine Ahnung hatte ;) Ich hab mit LODs bisher noch nichts umgesetzt. Ich wusste was es ist aber nicht wie und wo man es richtig einstellt. Jetzt bin ein ein bisschen schlauer.


    Lösung: Ich habe jetzt wie du vorgeschlagen hast alle LOD Stufen gelöscht, so nur noch eine vorhanden war, die LOD 0. Das hat jedenfalls mein Problemchen gelöst. Beim Reimport b.z.w initialen Import werden aber komischerweise immer mal LOD Stufen angelegt, obwohl ich die Option in den Importeinstellungen deaktiviert habe. Danach lösche ich die Stufen einfach wieder. Also erstmal nicht weiter tragisch.


    Danke für deinen Hinweis Sleepy

    Die UE ist für mich noch Neuland. So viele Fragen.

    Einmal editiert, zuletzt von Barni ()