Lightmap, Static Lighting Level Scale

  • Hallöle,

    ich bin gerade am verzweifeln an meiner Lightmap. Meine Lightmap zeigt immer wieder Seams wenn ich mein "Static Lighting Level Scale" auf 1 lasse. Schalte ich es auf 0.1 funktioniert alles einwandfrei. Nun an euch. Laut dem Tooltext geht ein Wert unter 1 deutlich auf die Renderzeit. Habt ihr damit bereits Erfahrungen, dauert es nur länger zu Baken und gut ist oder ist die Performance generell miese damit?


  • ja mit lichteinstellungen kann das sehr anstrengend sein, weils so viele möglichkeiten gibt. grundsätzlich würd ich auch eher an einzelnen lichtquellen basteln bzw an der map der objekte, als an generellen einstellungen.


    hast du im projekt andere sachen, bei denen es immer funktioniert? wenn nicht würd ich vergleichsobjekte hinzufügen.

  • Bis auf längere Render Zeit beim Lightmap bake sollte es keine Probleme machen (Lightmap Resolution hätte einen Einfluss)

    Aber eine richtige Map in Production Quality kann auch bei 1 ein paar Stunden benötigen wenn man in Production Quality baked.


    Eine Frage um es mal auszuschließen. Mit welcher Qualität startest du den bake? Den Fehler bekomme ich (unter anderem) auch hin und wieder wenn ich im Preview Mode bake, jedoch geht es meistens weg wenn man auf höherer Qualität den bake laufen lässt.

  • Mit welcher Qualität startest du den bake?

    Es machte nur einen Minimalen unterschied zwischen Preview und High (Was die Seams angeht natürlich)

    Meine aktuelle Lösung: "Movable Lights", nicht sehr sauber aber funktionell. Habe die LightRes vorher bereits auf verschiedenen Resolution getestet ((Sogar 2048p :D ) Ohne Erfolg)


    Wenn ich mir das so ansehe schreckt es schon sehr ab da etwas umzustellen^^ 0.2 ging bei mir auch noch, jedoch finde ich es schon krass wenn ich an eine große Map denke. Es wäre zu schön wenn ich eine Art Border hätte wie bei dem "LightmassImportanceVolume" wo ich die Settings für die Area einstellen könnte.


    So funktioniert es zumindest mal ohne das ich "Static Lighting Level Scale" verändern musste. Krass eigentlich wenn man überlegt das die Lightmap keinerlei Fehler hat.

  • Ist anhand eines Screenshots schwer zu sagen woran das liegt aber einfach mal ein paar Gedanken:


    1. ich glaube nicht, das meine Settings das Problem beheben.

    2.Deine Wände bestehen aus Planes was bedeutet überall ballert Licht durch, Somit können eigentlich von überall her Schatten geworfen werden.

    3.Ich hab das Gefühl, dass es nicht an den Settings liegt sondern eher ein UV oder Mesh Problem ist.

    4. Hast du die Light UVs selber erstellt oder dir beim Import erstellen lassen ?

    5.Mach mal Screenshots beider Lightuvs

    6.Haben beide Meshes die selbe Resolution? Drück mal ALT + 0 um die Light Density anzuzeigen und mach auch mal davon ein Screenshot.

    7. Ist vielleicht weit her geholt aber prüf mal bitte ob die Uvs richtig herum liegen. Wenn deine UVs geflippt sind, so dass die Normale Seite nach unten zeigen, könnte das eventuell zu solchen problemen führen. Ist wie gesagt nur eine Möglichkeit.

    8.Wenn die UVs richtig rum liegen, prüf auch ob die Normals korrekt sind.

    9.Prüfe ob du sicher keine überlappenden Light UVs hast?

    Sagen mal du hättest die Wand einmal extrudiert aber den Extrude nicht nach außen gezogen. (Es würden zwei Flächen exakt aufeinander liegen. Dann würde die Wand 2mal über backen werden wodurch die dunkler wäre als die anderen Wände. (nur so als Gedanke) = (Doppelte Geometrie Checken)




    10. Schalte die Schatten doch einmal komplett aus um ausschließen das von irgend woher doch Schatten erstellt wird.

    11.Schalte die Licht nacheinander aus und Bake jedesmal neu. Vielleicht findest du eine Lichtquelle die das Problem verursacht.


    Wie gesagt: Ich glaube nicht das es ein Setting Problem ist, ich würde dein Fehler beim Mesh, den UVs oder den Normals suchen.