Kleidung verschwindet beim Zoomen

  • Hallo Leute,


    ich habe ein Problem mit meiner Kleidung.

    Mein Charakter hat ein Kleidungsstück an. Wenn ich im mit der Kamera weit weg bin und laufe und schwenke ist alles gut. Zoome ich aber näher ran, verschwindet die Kleidung bei einer bestimmten Entfernung. Zoome ich wieder zurück ist die Kleidung wieder da. Wie oder wo kann ich das einstellen das die Kleidung nicht verloren geht?

    Ist jedoch nicht bei allen Kleidungsstücken so. Was habe ich da schon wieder falsch gemacht.


    Gruß

  • Ganz so schlimm ist der Fehler ja nicht :D

    Spaß beiseite, hast du mal deine LOD´s auf ihre Korrektheit gescheckt? Gehe auf das entsprechende Kleidungsstück und stelle im Viewport das Maximale LOD ein. Verschwindet hier dein entsprechendes Objekt, hast du einen Fehler in deinem LOD.


    Lösung für die LOD´s wäre:

    Lösche alle bestehenden LOD´s und erstelle sie mal eben neu. Hierfür stückweiße die "decimate-function" oder "Screen Space Size" hochdrehen (Kenne gerade nicht die korrekte Bezeichnung, eines von beiden müsste es gewesen sein)


    Andernfalls kann ich mir noch vorstellen das du evt eine falsche Clip-Plane hast.

    Lösung:

    Settings > Engine > General Settings (Hier die Clip-Plane Distanz anpassen)

  • Im Character wird alles korrekt angezeigt. Nur im Spiel will es nicht.

    Das Problem hatte ich auch schon, aber keine Ahnung wie man es fixt, vielleicht hilft das Video von damals, damit andere evtl. ne Antwort wissen:

    Externer Inhalt www.youtube.com
    Inhalte von externen Seiten werden ohne Ihre Zustimmung nicht automatisch geladen und angezeigt.
    Durch die Aktivierung der externen Inhalte erklären Sie sich damit einverstanden, dass personenbezogene Daten an Drittplattformen übermittelt werden. Mehr Informationen dazu haben wir in unserer Datenschutzerklärung zur Verfügung gestellt.

    Ich denke mal, dass es das gleiche Problem ist ^^


    Das Video hatte ich damals nem Freund geschickt, welcher auch ab und zu das Problem hatte, jedoch ebenfalls keine Ahnung wieso...

  • Hallo Butter Fly Games,


    jau so ist das bei mir auch. Leider finde ich dazu keine Lösung. Das passiert wenn ich das Kleidungsstück exportiere und aus Blender dann wieder mit Pipeline Send to Unreal exportiere. Sonnst nicht. Aber wenn ich das in Blender importiere und dann verändere und dann normal als FBX wieder (ohne Send to Unreal) dann passt es nicht mehr auf das Skeleton.

    Obwohl ich das schon mal gemacht habe und es wunderbar und einfach wieder in die Unreal bekommen habe. Aber es scheint als bekäme ich Demenz ich weiß ums verrecken nicht mehr warum ich das jetzt nicht mehr hin bekomme.

  • Was Smily meint:


    1.LODs sind unterschiedliche Meshes mit unterschiedlichem Polycount. Wenn du Meshes irgend wo runterladen tust, dann haben diese oftmals unterschiedliche LODs die auch unterschiedlich eingestellt sind.
    Was meine ich mit unterschiedlich eingestellt ?

    LODs sind wie gesagt Meshes mit unterschiedlichem Polycount. Zoomt man näher ran, kann der Polycount höher sein. Zoomt man raus, sieht man den Charakter nicht mehr nahund ein Mesh mit niedrigem Polycount wird angezeigt.

    Frei nach dem Motto:

    Ist man Nah dran, werden wenige Meshes angezeigt diese aber mit einem hohen Polycount. Zoomt man raus, werden mehr Meshes angezeigt und diese mit weniger Polycount.

    Ist der Polycount falsch eingestellt, kann es sein, dass ein LOD gar nicht angezeigt wird.

    Was du tun müsstest, wäre zu prüfen ob dein Charakter LODs hat. Wenn ja würde ich die LODs erstmal rausnehmen um den Fehler durch LODs auszuschließen.



    2.

    Eine andere Möglichkeit: Du hast ein distance culling volume deiner Szene ohne es zu wissen.

    Das Distance Culling blendet Meshes ab einer gewissen Distance aus.


    3.

    Vielleicht hast du die Meshes in der Unreal Engine Skaliert oder bereits zu groß aus einem 3D Programm exportiert?

    Es gibt das sog. Occlusion Culling wenn das falsch eingestellst ist, können Meshes einfach ausgeblendet werden.


    Einfach mal in den Projects Settings unter Rendering/ Culling das Occlusion Culling deaktivieren und prüfen ob das Problem dann immer noch auftritt.

  • Hallo,


    ok ich hab`s wieder. Zu blöde sowas dummes.

    Ich exportiere das Kleidungsstück. Importiere es in Blender. Dort bearbeiten. Blender nimmt beim importieren aber den Namen des Kleidungsstückes mit und setzt darunter erst alles andere. Also unter den Namen klicken so das alles markiert ist außer dem Namen des Kleidungsstückes. Beim Exportieren in FBX Selectes anklicken. Dan einfach wieder in die Unreal Importieren und das entsprechende Skeleton auswählen. Fertig

    Nix mit send to Unreal da werden keine LOD mitgenommen.

    So ein blöder Fehler.

    Sorry das ich euch damit genervt habe.


    Gruß

  • Sorry das ich euch damit genervt habe.

    Also ich glaube, außer mir ist hier nie einer genervt...


    Und deine Frage fand ich auch interessant, eben weil ich das selbe Problem hatte (nur dass ich nie dieses Blender-UE-Tool benutzte).

    Ich hab das Problem inzwischen nicht mehr, kann dir aber auch nicht sagen, was ich anders gemacht hatte ^^